...

Cuando aparece el anuncio de que el plugin (para leer PDFs dentro de una página web)  no funciona la opción es instalar Adobe Reader a mano. Esto de que el plugin no se encuentra parece estar solucionado en la versión 9.04 de Ubuntu (que sale en unos días).

Lo que hay que hacer es darle clic a la opción de bajar a mano o ir directamente a: http://get.adobe.com/reader/otherversions/ por defecto aparece una opción .bin. Hay que seleccionar la versión .deb (Debian / Ubuntu). Bajarla y darle doble clic para instalarla. El administrador de paquetes se encarga del resto.

Claro, esta es una versión de Adobe, cerrada. También se pueden probar otras opciones usando Synaptic.